BETA

26th July 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [26/07/19 11:37 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/07/19 01:39 PM]