BETA Singapore cluster       Mumbai cluster

26th July 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [26/07/19 11:37 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/07/19 01:39 PM]