BETA

25th July 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [25/07/19 08:41 PM] with 'Major Outage'

Issue has been resolved at [26/07/19 10:38 AM]