BETA

25th July 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/07/19 08:40 PM] with 'Major Outage'

Issue has been resolved at [26/07/19 10:40 AM]