BETA Singapore cluster       Mumbai cluster

23rd July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/07/19 04:57 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/07/19 05:43 PM]