BETA

23rd July 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [23/07/19 02:43 PM] with 'Major Outage'

Issue has been resolved at [23/07/19 02:49 PM]