BETA Singapore cluster       Mumbai cluster

23rd July 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/07/19 12:28 PM] with 'Major Outage'

Issue has been resolved at [23/07/19 12:30 PM]