BETA

23rd July 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/07/19 12:28 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/07/19 10:39 AM]