BETA

23rd July 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [23/07/19 12:28 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/07/19 01:49 PM]