BETA

4th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/05/17 06:06 AM] with 'Partial Outage'

Issue has been resolved at [04/05/17 06:07 AM]