BETA

23rd July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/07/19 08:58 AM] with 'Major Outage'

Issue has been resolved at [23/07/19 08:59 AM]