BETA

22nd July 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/07/19 08:22 PM] with 'Partial Outage'

Issue has been resolved at [22/07/19 08:28 PM]