BETA Singapore cluster       Mumbai cluster

22nd July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [22/07/19 10:02 AM] with 'Partial Outage'

Issue has been resolved at [22/07/19 10:03 AM]