BETA

15th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/03/19 07:20 PM] with 'Partial Outage'

Issue has been resolved at [15/03/19 07:21 PM]