BETA

21st July 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [21/07/19 11:44 AM] with 'Partial Outage'

Issue has been resolved at [21/07/19 11:48 AM]