BETA

21st July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [21/07/19 11:18 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/07/19 11:48 AM]