BETA Singapore cluster       Mumbai cluster

20th July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [20/07/19 05:00 PM] with 'Partial Outage'

Issue has been resolved at [20/07/19 05:08 PM]