BETA

20th July 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [20/07/19 08:02 AM] with 'Partial Outage'

Issue has been resolved at [20/07/19 08:07 AM]