BETA

17th July 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [17/07/19 01:48 PM] with 'Major Outage'

Issue has been resolved at [17/07/19 01:50 PM]