BETA

5th October 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [05/10/18 02:08 PM] with 'Partial Outage'

Issue has been resolved at [05/10/18 02:20 PM]