BETA Singapore cluster       Mumbai cluster

16th July 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/07/19 09:46 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/07/19 01:56 PM]