BETA

16th July 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/07/19 07:00 AM] with 'Major Outage'

Issue has been resolved at [16/07/19 07:44 AM]