BETA

4th May 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [04/05/17 05:57 AM] with 'Partial Outage'

Issue has been resolved at [04/05/17 08:10 AM]