BETA

14th July 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [14/07/19 05:47 AM] with 'Major Outage'

Issue has been resolved at [14/07/19 06:04 AM]