BETA

9th July 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [09/07/19 01:20 AM] with 'Partial Outage'

Issue has been resolved at [09/07/19 01:21 AM]