BETA

3rd July 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [03/07/19 04:21 PM] with 'Major Outage'

Issue has been resolved at [03/07/19 04:22 PM]