BETA

5th October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/10/18 01:02 PM] with 'Partial Outage'

Issue has been resolved at [05/10/18 01:03 PM]