BETA

3rd July 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [03/07/19 01:17 AM] with 'Partial Outage'

Issue has been resolved at [03/07/19 01:19 AM]