BETA

5th October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [05/10/18 12:45 PM] with 'Major Outage'

Issue has been resolved at [05/10/18 12:49 PM]