BETA

5th October 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [05/10/18 12:10 PM] with 'Partial Outage'

Issue has been resolved at [05/10/18 12:16 PM]