BETA

22nd July 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [22/07/16 08:04 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/07/16 08:10 PM]