BETA

5th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/10/18 11:57 AM] with 'Partial Outage'

Issue has been resolved at [05/10/18 12:01 PM]