BETA

15th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [15/03/19 07:01 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/03/19 07:04 PM]