BETA

1st July 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [01/07/19 03:06 PM] with 'Major Outage'

Issue has been resolved at [01/07/19 03:07 PM]