BETA

15th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/03/19 06:56 PM] with 'Partial Outage'

Issue has been resolved at [15/03/19 07:05 PM]