BETA

4th October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/10/18 05:43 PM] with 'Partial Outage'

Issue has been resolved at [04/10/18 05:44 PM]