BETA

4th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/10/18 05:42 PM] with 'Partial Outage'

Issue has been resolved at [04/10/18 05:43 PM]