BETA

3rd May 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [03/05/17 09:48 PM] with 'Major Outage'

Issue has been resolved at [03/05/17 09:49 PM]