BETA

4th October 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/10/18 11:19 AM] with 'Partial Outage'

Issue has been resolved at [04/10/18 11:22 AM]