BETA

3rd May 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [03/05/17 09:13 PM] with 'Major Outage'

Issue has been resolved at [03/05/17 10:13 PM]