BETA

3rd October 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [03/10/18 11:25 PM] with 'Major Outage'

Issue has been resolved at [03/10/18 11:27 PM]