BETA

21st July 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [21/07/16 06:37 AM] with 'Partial Outage'

Issue has been resolved at [21/07/16 06:42 AM]