BETA

2nd October 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [02/10/18 09:22 AM] with 'Major Outage'

Issue has been resolved at [02/10/18 09:23 AM]