BETA

1st October 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/10/18 09:25 PM] with 'Partial Outage'

Issue has been resolved at [01/10/18 09:28 PM]