BETA

1st October 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [01/10/18 01:52 PM] with 'Partial Outage'

Issue has been resolved at [01/10/18 01:53 PM]