BETA

1st October 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [01/10/18 12:32 AM] with 'Partial Outage'

Issue has been resolved at [01/10/18 12:33 AM]