BETA

2nd May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [02/05/17 03:35 AM] with 'Partial Outage'

Issue has been resolved at [02/05/17 03:36 AM]