BETA

30th September 2018

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [30/09/18 12:34 PM] with 'Partial Outage'

Issue has been resolved at [30/09/18 12:37 PM]