BETA

30th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/09/18 11:08 AM] with 'Partial Outage'

Issue has been resolved at [30/09/18 11:09 AM]