BETA

29th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/09/18 07:35 PM] with 'Major Outage'

Issue has been resolved at [29/09/18 07:36 PM]